Nexcloud 升级到16.04过程中遇到的问题

Nextcloud更新到16.04版本后,Web端后台无法显示更新按钮,于是进入服务器用occ命令手动升级,结果出现如下错误.

PHP Fatal error: Uncaught Doctrine\DBAL\DBALException: Failed to connect to the database: An exception occured in driver: could not find driver in /var/www/html/nextcloud/lib/private/DB/Connection.php:64

网上找了半天解决方案,疑似PHP的版本不对导致,于是参考这篇文章将PHP版本从7.0升级到了7.3。同时删除了旧的7.0和7.1版本,问题解决。

PHP版本升级过程中几个比较常用的命令

1.查看历史php版本安装的扩展

dpkg -l | grep php | tee packages.txt

2.php版本删除

apt purge php7.2 php7.2-common 
11

本文由作者 Rebaka 发布在 TNEXT , 转载请联系[email protected]授权处理,获得授权后请保留文章的完整性并附上原文链接: https://tnext.org/4282.html

Tags:

We will be happy to hear your thoughts

发表评论

error: Content is protected !
TNEXT